(trop ancien pour répondre)
codes de champ et mise en forme
"etudes" <ENLEVERuesl.etudes@@wanadoo.fr>
2004-04-07 10:42:04 UTC
Bonjour,

j'ai une config Word 2002 SP3
la source du publipostage est un fichier excel, les cellules sont au format
nombre avec séparateur de milliers.
le but du jeu est de faire apparaitre ce séparateur de milliers également
dans le publipostage.
ex: dans la cellule du champ toto on a le nombre 123 456,78 au format nombre
avec séparateurs de milliers.
dans Word, on a un champ { MERGEFIELD toto } qui s'affiche 123456,78 donc
sans le séparateur.
en insérant les commutateurs comme suit { MERGEFIELD toto \# # 000,00 }
ou { MERGEFIELD toto # "# 000,00;-# 000,00;" }
et de je ne sais combien de manières différentes ça ne fait pas avancer le
problème , au contraire avec{ MERGEFIELD toto \# # 000,00 } on arrive même à
se faire sucrer les décimales au passage.
existe-t-il une solution pour avoir automatiquement le séparateur de
milliers dans Word? avec \* mergefromat ça ne change rien au problème...

merci de votre aide
Anacoluthe
2004-04-07 19:26:37 UTC
Bonjour !

'etudes' nous a écrit ...
Post by "etudes" <ENLEVERuesl.etudes@@wanadoo.fr>
j'ai une config Word 2002 SP3
la source du publipostage est un fichier excel, les cellules sont au format
nombre avec séparateur de milliers.
le but du jeu est de faire apparaitre ce séparateur de milliers
dans Word, on a un champ { MERGEFIELD toto } qui s'affiche 123456,78 donc
sans le séparateur.
en insérant les commutateurs comme suit { MERGEFIELD toto \# # 000,00 }
ou { MERGEFIELD toto # "# 000,00;-# 000,00;" }
et de je ne sais combien de manières différentes ça ne fait pas avancer le
problème
Dans vos commutateurs de format numérique vous devez reprendre
le séparateur des milliers défini dans vos options régionales
du système, en français l'espace insécable (Ctrl+Maj+Espace)
{ MERGEFIELSD toto \# "#°##0,00" }

Ça c’est la solution Word, et elle marche ! Sinon il y
a la solution Excel du 'formatage en dur' par opposition
au formatage soft avec Format/Cellule qui est un formatage
d'affichage ne modifiant en rien les valeurs et surtout qui
n'est jamais transmis en tant que tel à Word.
Le formatage en dur consiste à utiliser une colonne
supplémentaire de données *texte* de type
=TEXTE(A1;"# ##0,00")
et d'utiliser cette donnée *texte* pour le publipostage

Mais faites encore quelques essais avec les commutateurs
Word et dites-nous ce que deviennent vos sépararateurs...

Anacoluthe
« Il n'est si bonne compagnie qui ne se sépare. »
- Proverbe français
jaklou
2004-04-15 04:42:22 UTC
Merci beaucoup Anacoluthe
Post by Anacoluthe
Bonjour !
'etudes' nous a écrit ...
Post by "etudes" <ENLEVERuesl.etudes@@wanadoo.fr>
j'ai une config Word 2002 SP3
la source du publipostage est un fichier excel, les cellules sont au format
nombre avec séparateur de milliers.
le but du jeu est de faire apparaitre ce séparateur de milliers
dans Word, on a un champ { MERGEFIELD toto } qui s'affiche 123456,78 donc
sans le séparateur.
en insérant les commutateurs comme suit { MERGEFIELD toto \# # 000,00 }
ou { MERGEFIELD toto # "# 000,00;-# 000,00;" }
et de je ne sais combien de manières différentes ça ne fait pas avancer le
problème
Dans vos commutateurs de format numérique vous devez reprendre
le séparateur des milliers défini dans vos options régionales
du système, en français l'espace insécable (Ctrl+Maj+Espace)
{ MERGEFIELSD toto \# "#°##0,00" }
Ça c’est la solution Word, et elle marche ! Sinon il y
a la solution Excel du 'formatage en dur' par opposition
au formatage soft avec Format/Cellule qui est un formatage
d'affichage ne modifiant en rien les valeurs et surtout qui
n'est jamais transmis en tant que tel à Word.
Le formatage en dur consiste à utiliser une colonne
supplémentaire de données *texte* de type
=TEXTE(A1;"# ##0,00")
et d'utiliser cette donnée *texte* pour le publipostage
Mais faites encore quelques essais avec les commutateurs
Word et dites-nous ce que deviennent vos sépararateurs...
Anacoluthe
« Il n'est si bonne compagnie qui ne se sépare. »
- Proverbe français